Follow

Is my iOS Device Compatible?

Triple Town is compatible with the iPhone 3GS and higher, with all versions of iPad, and with iPod Touch 3rd Gen and higher. It does *not* run on iPhone 3G, or on the 1st and 2nd Gen iPod Touches, and it is unlikely that this will change.

In addition to the above hardware requirements, Triple Town requires iOS 5.1 or later. If your device has an earlier version of iOS, syncing your device with iTunes should allow you to update your iOS to a newer version.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk